[gs-bugs] [Bug 690960] Issue with pswrite device: Thai characters with accent are not printed at the correct place

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Fri Aug 6 15:06:34 UTC 2010


http://bugs.ghostscript.com/show_bug.cgi?id=690960

--- Comment #12 from Ken Sharp <ken.sharp at artifex.com> 2010-08-06 15:06:32 UTC ---
(In reply to comment #11)
> (In reply to comment #10)
> > Re-opening this. I am able to see the incorrect output on any device, such
> > as the 'display' device. It still shows up with HEAD (r11600)
> > 
> > Sorry, Ken.
> 
> If it's wrong on any device, then its not a pswrite/ps2write/pdfwrite problem,
> so its a font problem and should probably belong to Chris ;-) I will look
> tomorrow.

The first thing that's wrong is using 'Identity' in the cidfmap file, it should
be 'Unicode'. Without that the CID decoding won't work properly, which is
almost certainly why comment #7 says the output is even worse with 8.70.

The output for me after that change matches the 'wrong' output in the customer
screenshot. 

However, I am unable to see how the 'correct' PDF was obtained, Acrobat won't
use the TrueType font as a replacement for the CIDFont, and Ghostscript's
pdfwrite device unsurprisingly produces the same output as the rendering
devices.

At the moment I can't say that this is a GS problem as opposed to a font
problem, I would need to see the font supplied being used in some way that
proves it does work.

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list