[gs-bugs] [Bug 689756] process CPU spin then SIGSEGV when rendering user defined font

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Sat May 8 18:09:11 UTC 2010


http://bugs.ghostscript.com/show_bug.cgi?id=689756

--- Comment #15 from James Cloos <cloos at jhcloos.com> 2010-05-08 18:09:10 UTC ---
Even with the icc branch (up to date, and as such almost up to date with
trunk),
when I run that file at any resolution with any device it works when FAPI is
used and crashes when -dDisableFAPI=true.

And 8.71 never works.

Gentoo’s patches for 8.71, based on reading the ebuild as I have it installed,
are borrowed from fedora and so should be similar to what you have.

Maybe you just have more ram installed?

I used this when I configured my compile of the icc branch:

env CFLAGS='-march=pentium3 -O2 -ggdb' ./configure --prefix=/opt/iccgs
--build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --enable-cairo
--disable-cups --enable-gtk --with-jasper --with-x --disable-compile-inits
--enable-dynamic --enable-fontconfig --with-drivers=ALL --with-ijs
--with-jbig2dec --with-libpaper --with-jbig2dec

that was mostly grabbed from the logs of my last system build of 8.71, with a
different prefix, cups disabled (because it tries to install to cups’ prefix
rather than to gs’s prefix) and -ggdb added to the CFLAGS.

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list