[gs-bugs] [Bug 691302] New: Building the installer on Windows fails if UAC is enabled

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Fri May 14 05:18:15 UTC 2010


http://bugs.ghostscript.com/show_bug.cgi?id=691302

           Summary: Building the installer on Windows fails if UAC is
                    enabled
           Product: Ghostscript
           Version: 8.70
          Platform: PC
        OS/Version: Windows 7
            Status: NEW
          Severity: normal
          Priority: P4
         Component: Config/Install
        AssignedTo: support at artifex.com
        ReportedBy: trejkaz at trypticon.org
         QAContact: gs-bugs at ghostscript.com
   Estimated Hours: 0.0


Some time in the past 3 weeks, our automated builds of Ghostscript stopped
working with this mysterious error:

     [exec]     make_filelist.exe -title "GPL Ghostscript 8.70" -dir "gs8.70"
-list "filelist.txt" @gs8.70\obj\dwfiles.rsp
     [exec] NMAKE : fatal error U1045: spawn failed : No error
     [exec] Stop.

On investigating, it turned out that the executable had the shield icon,
requiring admin access to run, and when running as an automated process, it
failed to get this access, thus causing the build failure.

If the build is run as the admin user, the build passes, but it shouldn't need
to be admin just to *build* the installer.

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list