[gs-bugs] [Bug 691955] Missing CIDFmap?

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Tue Feb 15 03:12:12 UTC 2011


http://bugs.ghostscript.com/show_bug.cgi?id=691955

Dickson <iswslui at ust.hk> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WORKSFORME                  |

--- Comment #16 from Dickson <iswslui at ust.hk> 2011-02-15 03:12:12 UTC ---
Thanks again.

I move the fonts to the accessible folder /Resource/Font and also modify the
cidfmap file. Then I run gs command with "-dPARANOIDSAFER" and the ps file is
generated without any error. I use "lp" command to print it in CUPS and get an
error. Then I download the 2 ps files from Solaris 10 to Windows for viewing.
Both of them are generated with gs9.00 (same option).

PS file 1  ( from PDF with embedded font)
-----------------------------------------
- can be printed in Solaris 10 ("lp" in cups)
- can be viewed in Solaris 10 by "vi"
- can be viewed in Windows XP by GSview
- can be viewed in Notepad / editor (content as below)
%!PS-Adobe-3.0
%%BoundingBox: 0 0 612 792
%cupsRotation: 0
.....
.....


sam.ps  ( from PDF without embedded font, the error one)
------------------------------------------------------------
- cannot be printed in Solaris 10 ("lp" in cups)
- cannot be viewed in Solaris 10 by "vi" (strange character) 
- cannot be viewed in Windows XP by GSview (with error)
- cannot be viewed in Notepad / editor (strange character as below)
RaS3ÿø‡8`
óƒ÷þ€ç

ÿœÿÿÿÿÿÿÿÿÿÀÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÀàÿÿÿÿßUÿÿwÿÿÓÿÿÿÿÀÿýÀ
 ÷ÿÿÿÿÿÿÿÿÿ¾ÿÿÿÿÿÿÀ†ùæ£3|ÿïüz£ðõ„È0.ÃÜ}ŒÀ0.....
.....


Therefore, if GS generates a ps file successfully, it should be viewed by any
editor. However, the converted "sam.ps" just have a lot of strange character.
That is why I think the generation is not completed. I attach an output log
"gs_output.log" of this generation and the converted ps file "sam.ps"
for your investigation. From the line 7060 of gs_output.log, you will see the
font mapping (Font MHei-Medium -> Font ming). Without error in GS generation,
ps file cannot be viewed/printed. Any idea? Is anything wrong? 


gs command run on Solaris 10
--------------------------------------------------------------------
# /usr/local/bin/gs -dPARANOIDSAFER -dNOPAUSE
-I/usr/local/share/ghostscript/9.00/Resource/Init -dDEBUG -dBATCH
-dNOMEDIAATTRS -sDEVICE=cups -sOUTPUTFILE=sam.ps -c -f sam.pdf > gs_out.log
INFO: Start rendering...
INFO: Processing page 1...
INFO: Processing page 2...
INFO: Processing page 3...
INFO: Rendering completed
#


Thanks in advance for your help.

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list