[gs-bugs] [Bug 691993] New: PCL files using rops don't work on the display device

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Mon Feb 21 12:54:05 UTC 2011


http://bugs.ghostscript.com/show_bug.cgi?id=691993

           Summary: PCL files using rops don't work on the display device
           Product: GhostPCL
           Version: trunk
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P4
         Component: PCL interpreter
        AssignedTo: henry.stiles at artifex.com
        ReportedBy: robin.watts at artifex.com
         QAContact: gs-bugs at ghostscript.com
   Estimated Hours: 0.0


Created an attachment (id=7271)
 --> (http://bugs.ghostscript.com/attachment.cgi?id=7271)
simpler.pcl

On windows, using the display device on files with rops in gives incorrect
results. For example:

 main/obj/pcl6.exe -sDEVICE=display simple.pcl

I first noticed this using -sDEVICE=display -dDisplayFormat=16#20101 to try and
reproduce what I saw using -sDEVICE=pbmraw and then loading it into xli on
linux.

On windows, debug and release builds are different (but both wrong).

Attached is a cut down pcl file that shows the problem:

 Esc * v 1 N         Source Transparency = Opaque
 Esc * l 17 0        Rop13 = 17

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list