[gs-bugs] [Bug 691904] New: IJS support can only be built with the shipped source, not with an external shared library

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Mon Jan 24 10:06:26 UTC 2011


http://bugs.ghostscript.com/show_bug.cgi?id=691904

           Summary: IJS support can only be built with the shipped source,
                    not with an external shared library
           Product: Ghostscript
           Version: HEAD
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P4
         Component: Build Process
        AssignedTo: support at artifex.com
        ReportedBy: till.kamppeter at gmail.com
         QAContact: gs-bugs at ghostscript.com
   Estimated Hours: 0.0


At least on Linux and Unix shared libraries provided by the system can be used
for everything (libpng, libtiff, ...) except libijs. libijs is available
separately on

http://www.openprinting.org/download/ijs/

and ships with most Linux distributions as it is used by the printer driver
packages gutenprint, epsonepl, and others. One could save some duplicate code
and simplify bug fixes if the Ghostscript packages coming with Linux
distributions uses the system-provided libijs and not the libijs source code
which comes with Ghostscript.

Can you add support for using the system's libijs for 9.01? Should work the
same way as with libpng, libtiff, ...

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list