[gs-bugs] [Bug 692328] sed pstopxl.in is using perl regex which is not portable (not standard or posix)

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Wed Jul 27 06:40:44 UTC 2011


http://bugs.ghostscript.com/show_bug.cgi?id=692328

--- Comment #3 from jirib <jirib at devio.us> 2011-07-27 06:40:43 UTC ---
detection if using GNU sed or "other" sed is OK, my complain is that you use
perl regex style which is not covered in every "other" sed programs. That's it.

So as most "other" sed programs are POSIX compatible I created this diff to
replace perl regex (this is probably used only by GNU sed) with different regex
style (POSIX) to have it running on every sed which exists.

I don't understand why are you so defending perl regex in sed? :)

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list