[gs-bugs] [Bug 692383] New: Regression: UFST build broken

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Fri Jul 29 03:35:55 UTC 2011


http://bugs.ghostscript.com/show_bug.cgi?id=692383

           Summary: Regression: UFST build broken
           Product: Ghostscript
           Version: master
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P4
         Component: General
        AssignedTo: robin.watts at artifex.com
        ReportedBy: marcos.woehrmann at artifex.com
         QAContact: gs-bugs at ghostscript.com


Starting with 6039e0750306e2c3442b03c9ed5f7afee33a5540 the UFST build of
Ghostscript no longer runs with any input file: 

GPL Ghostscript GIT PRERELEASE 9.04 (2011-03-30)
Copyright (C) 2010 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Unrecoverable error: rangecheck in readline
Operand stack:
    2  --nostringval--  Wingdings-Regular  --nostringval--  --nostringval--  0
Albertus-Medium 1 Albertus-ExtraBold 2 AntiqueOlive 3 AntiqueOlive-Italic 4
AntiqueOlive-Bold 5 Arial 6 Arial-Italic 7 Aria
l-Bold 8 Arial-BoldItalic 9 Clarendon-Condensed-Bold 10 Coronet 11 CourierHP 12
CourierHP-Italic 13 CourierHP-Bold 14 CourierHP-Bol


Here is the command line I'm using:

./bin/gs -Ilib -o test.pgm -sDEVICE=pgmraw
-sFCOfontfile=/home/marcos/weekly/Thu/ghostpdl/ufst/fontdata/mtfonts/pclps2/mt3/pclp2_xj.fco
-sFCOfontfile2=/home/marcos/weekly/Thu/ghostpdl/ufst/fontdata/mtfonts/pcl45/mt3/wd____xh.fco
-sUFST_PlugIn=/home/marcos/weekly/Thu/ghostpdl/ufst/fontdata/mtfonts/pcl45/mt3/plug__xi.fco
-sFAPIfontmap=FCOfontmap-PCLPS2 -sFAPIconfig=FAPIconfig-FCO ./alphabet.ps

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list