[gs-bugs] [Bug 691883] segfault with <</UseCIEColor true>>setpagedevice

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Sun Oct 16 01:13:16 UTC 2011


http://bugs.ghostscript.com/show_bug.cgi?id=691883

--- Comment #16 from Volker Kuhlmann <list0570 at paradise.net.nz> 2011-10-16 01:13:14 UTC ---
Thanks Ray. I am not explicitly setting any prefix file beyond what gs runs
with these commands:

echo "This resulting PDF will segfault ghostscript"
date >test-gs
enscript --media=A4 --output=- --mark-wrapped-lines=arrow --ps-level=1 \
 --font=Courier10 --baselineskip 1.0 --columns=1 --portrait --marg=50 \
 --header='test-gs|$D{%a %d-%h-%Y %T}|Page $% of $=         ' \
 --no-header --title=test-gs test-gs \
 > test-gs.ps
ps2pdf14 -sPAPERSIZE=a4 -dFIXEDMEDIA -dPDFSETTINGS=/printer \
 -dMaxSubsetPct=100 -dSubsetFonts=true -dEmbedAllFonts=true \
 -dCompressFonts=true -dUseCIEColor -dHaveTrueTypes=true \
 -dHaveTransparency=true \
 test-gs.ps
echo "(test-gs.pdf)run" | gs

Which to be honest I was just expecting to work, it has for the past umpteen
years but it doesn't with gs 9.00.
Originally I reported that in
http://bugs.ghostscript.com/show_bug.cgi?id=692370
I can't say whether this has anything to do with this WTS. The above works
again in gs 9.02, but if that (by any path) uses this WTS there will be a
problem again. If it doesn't have anything to do with WTS problem solved (well
for gs, not for Linux systems, they can't just upgrade gs).

-- 
Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.


More information about the gs-bugs mailing list