[gs-bugs] [Bug 691985] Text is sometimes omitted when printing from a HP printer

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Mon Feb 28 10:19:27 UTC 2011


--- Comment #6 from Ken Sharp <ken.sharp at artifex.com> 2011-02-28 10:19:23 UTC ---
(In reply to comment #5)
> From the discussion in the referenced Gentoo bug, this is a duplicate of bug
> 691961 (which is marked as WORKSFORME even when it still doesn't work).

That's because nobody has followed up with any newer information. From the

"But, without knowing how CUPS is invoking Ghostscript, there isn't really a
I can offer in the way of advice.

I'm going to close this as 'WORKSFORME', feel free to reopen it if you can find
a Ghostscript command line which shows the problem."

Running Ghostscript on the file supplied here *also* works correctly (by the
way, despite the name and MIME type this is in fact a PDF file). I do not doubt
that the printed output is incorrect, but we have no idea how this print out
was created. (I'm assuming the file was printed through CUPS, just like the
report in #691961) In fact we don't even know for sure that Ghostscript was
involved in the print path at all, but the fact that reverting to an earlier
build works suggests that it is.

Neither this report nor #691961 supply an example command line for Ghostscript
which can be used to reproduce the problem. In the absence of this I cannot
reproduce the issue (I *have* tried) and if I can't reproduce it its well-nigh
impossible to fix it.

If someone would please like to use the script supplied by Oldrich (apologies,
I can't seem to reproduce the r macron in your name) in comment #14 of bug
#691971 then it should be possible to retrieve the command line being sent to
Ghostscript by CUPS. That should allow us to reproduce the problem. Any other
means of retrieving the Ghostscript command being used is of course also good.

In the absence of a Ghostscript command line we aren't going to be able to
resolve this. We may need more information, but we can't even tell that at the

The only thing which springs to mind is that the operation of SAFER was altered
in recent versions of Ghostscript (at the instigation of Linux distributors
concerned about security issues) and this *might* be the source of the problem.

This is pure speculation of course.

Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the gs-bugs mailing list