[gs-bugs] [Bug 692252] New: GS fails to read some PDF files

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Mon Jun 6 01:28:33 UTC 2011


           Summary: GS fails to read some PDF files
           Product: Ghostscript
           Version: 9.02
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P4
         Component: PDF Interpreter
        AssignedTo: alex.cherepanov at artifex.com
        ReportedBy: kerplatz.ia at netzero.net
         QAContact: gs-bugs at ghostscript.com
   Estimated Hours: 0.0

Created an attachment (id=7564)
 --> (http://bugs.ghostscript.com/attachment.cgi?id=7564)
The PDF file that causes the error

I get this error when I run GhostScript on some PDF files.

kerplatz at kerplatz-laptop:~/Desktop/test/d20110411/56153$ gs
GPL Ghostscript 9.02 (2011-03-30)
Copyright (C) 2010 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1
Loading NimbusSanL-Bold font from %rom%Resource/Font/NimbusSanL-Bold... 2547264
1216775 4055652 2758613 3 done.
   **** Unknown operator: 'inf'
Error: /typecheck in --run--
Operand stack:
   --dict:8/17(L)--   266.285   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1894   1   3   %oparray_pop  
1893   1   3   %oparray_pop   1877   1   3   %oparray_pop   --nostringval--  
--nostringval--   2   1   1   --nostringval--   %for_pos_int_continue  
--nostringval--   --nostringval--   --nostringval--   --nostringval--  
%array_continue   --nostringval--   false   1   %stopped_push   --nostringval--
  %loop_continue   --nostringval--
Dictionary stack:
   --dict:1150/1684(ro)(G)--   --dict:1/20(G)--   --dict:82/200(L)--  
--dict:82/200(L)--   --dict:108/127(ro)(G)--   --dict:295/300(ro)(G)--  
--dict:23/30(L)--   --dict:6/8(L)--   --dict:22/40(L)--   --dict:7/15(L)--
Current allocation mode is local
Last OS error: 11
GPL Ghostscript 9.02: Unrecoverable error, exit code 1

I am including a PDF file that has this error. I have the latest Linux OS
updates and GhostScript is also the latest. I am using ImageMagick to create
JPG files from several PDFs, but as you can see I also get the same error when
I run GS at the command line. By removing IM from the equation, I am betting it
is not the problem.

I need this solved and am willing to help in solving the problem, but I have no
idea on where to start. Thanks.

Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the gs-bugs mailing list