[gs-bugs] [Bug 692266] New: Application Crashes with Fatal Memory Error

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Wed Jun 8 19:46:11 UTC 2011


           Summary: Application Crashes with Fatal Memory Error
           Product: MuPDF
           Version: unspecified
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P4
         Component: mupdf
        AssignedTo: tor.andersson at artifex.com
        ReportedBy: pedro.rivera.651 at gmail.com
         QAContact: gs-bugs at ghostscript.com
   Estimated Hours: 0.0

Created an attachment (id=7579)
 --> (http://bugs.ghostscript.com/attachment.cgi?id=7579)
PDF causing memory crash.

I am getting a very strange error with a pdf document. When I run pdfdraw.exe I
get the following error:

pdfdraw -0 test1.png -r 250 sample01.pdf

The instruction at "0x77c3554a" referenced memory at "0x00000000a7". The memory
could not be "read".

If I run the command with a resolution of less than 144 I get no errors:

I am getting the exact same error in my Java code (JMuPDF):

# A fatal error has been detected by the Java Runtime Environment:
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x77c3554a, pid=1592, tid=3800

I was able to pinpoint the error to the following line:

  fz_execute_display_list(hdoc->page_list, dev, ctm, bbox);

I have attached the PDF.

Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the gs-bugs mailing list