[gs-bugs] [Bug 692310] New: Emedded fonts with UTF-8 support printed as squares / blocks

bugzilla-daemon at ghostscript.com bugzilla-daemon at ghostscript.com
Tue Jun 28 17:32:13 UTC 2011


           Summary: Emedded fonts with UTF-8 support printed as squares /
           Product: Ghostscript
           Version: 9.02
          Platform: All
        OS/Version: All
            Status: UNCONFIRMED
          Severity: major
          Priority: P4
         Component: Font API
        AssignedTo: chris.liddell at artifex.com
        ReportedBy: maarten at xolphin.nl
         QAContact: gs-bugs at ghostscript.com

Created an attachment (id=7621)
 --> (http://bugs.ghostscript.com/attachment.cgi?id=7621)
PDF with embedded UTF-8 font

After upgrading from Fedora 14 to Fedora 15 with Ghostscript 9.02, we couldn't
print any of our self generated PDF documents anymore. Instead of normal text
we get little squares / blocks with or no text at all.

We use CUPS for printing documents, but the following Ghostscript command gives
exactly the same result:

 gs -sDEVICE=png16m -sOUTPUTFILE=foo.png -q -dNOPAUSE foo.pdf -c quit

The PDF's are generated with tFPDF which can be found on 
http://fpdf.org/en/script/script92.php. The example there
(http://fpdf.org/en/script/ex92.pdf) gives the exact same error.

Configure bugmail: http://bugs.ghostscript.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the gs-bugs mailing list