[gs-devel] help with "FC_WEIGHT didn't match" on cygwin

David Leung dcltdw at gmail.com
Fri Feb 7 16:08:24 UTC 2020


Hi, all.
I'm going slightly nuts.  My gs setup on cygwin suddenly can't find
installed fonts.
The new error is

DEBUG: FC_WEIGHT didn't match


I believe the change is from these cygwin lib changes:

2020/02/06 13:49:55    0 install
 libgmp10             6.2.0-1
2020/02/06 13:49:55    1   erase
 libgmp10             6.1.2-1
2020/02/06 13:49:55    2 install
 libsasl2_3            2.1.27-1
2020/02/06 13:49:55    3   erase
 libsasl2_3           2.1.26-11
2020/02/06 13:49:55    4 install
 libid3tag0          0.15.1b-10
2020/02/06 13:49:55    5 install
libmad0          0.15.1b-11
2020/02/06 13:49:55    6 install
libogg0             1.3.1-1
2020/02/06 13:49:55    7 install
 libsoxr0             0.1.2-1
2020/02/06 13:49:55    8 install
libtwolame0            0.3.13-2
2020/02/06 13:49:55    9 install
libmp3lame0             3.100-1
2020/02/06 13:49:55   10 install
libportaudio2       19.20140130-3
2020/02/06 13:49:55   11 install
 libSoundTouch1             2.0.0-1
2020/02/06 13:49:55   12 install
 libwx_baseu3.0_0             3.0.4-1
2020/02/06 13:49:55   13 install
libgstreamer1.0_0            1.12.5-1
2020/02/06 13:49:55   14 install
 libmspack0               0.8-1
2020/02/06 13:49:55   15 install
 libnotify4             0.7.7-1
2020/02/06 13:49:55   16 install
 libsamplerate0             0.1.8-1
2020/02/06 13:49:55   17 install
libvorbis             1.3.6-1
2020/02/06 13:49:55   18 install
libgsm1            1.0.17-1
2020/02/06 13:49:55   19 install
 libdbus1_3           1.10.22-1
2020/02/06 13:49:55   20 install
 libXi6            1.7.10-1
2020/02/06 13:49:55   21 install
 libXinerama1             1.1.4-1
2020/02/06 13:49:55   22 install
 libXrandr2             1.5.2-1
2020/02/06 13:49:55   23 install
libXss1             1.2.3-1
2020/02/06 13:49:55   24 install
gtk-update-icon-cache           3.22.28-1
2020/02/06 13:49:55   25 install
libatk1.0_0            2.26.1-1
2020/02/06 13:49:55   26 install
 libXcomposite1             0.4.5-1
2020/02/06 13:49:55   27 install
libXdamage1             1.1.5-1
2020/02/06 13:49:55   28 install
 libXfixes3             5.0.3-1
2020/02/06 13:49:55   29 install
iso-codes               4.3-1
2020/02/06 13:49:55   30 install
liborc0.4_0            0.4.28-1
2020/02/06 13:49:55   31 install
 hicolor-icon-theme              0.15-1
2020/02/06 13:49:55   32 install
 libFLAC8             1.3.2-1
2020/02/06 13:49:55   33 install
 libvorbis0             1.3.6-1
2020/02/06 13:49:55   34 install
libXcursor1             1.2.0-1
2020/02/06 13:49:55   35 install
libgstinterfaces1.0_0            1.12.5-1
2020/02/06 13:49:55   36 install
 adwaita-icon-theme            3.26.1-1
2020/02/06 13:49:55   37 install
 libFLAC++6             1.3.2-1
2020/02/06 13:49:55   38 install
 libvorbisfile3             1.3.6-1
2020/02/06 13:49:55   39 install
libvorbisenc2             1.3.6-1
2020/02/06 13:49:55   40 install
libSDL2_2.0_0             2.0.7-1
2020/02/06 13:49:55   41 install
libgtk2.0_0           2.24.32-1
2020/02/06 13:49:55   42 install
libsndfile1            1.0.28-2
2020/02/06 13:49:55   43 install
 libwx_gtk2u3.0_0             3.0.4-1
2020/02/06 13:49:55   44 install
 audacity             2.2.1-1


But I have no idea why those libs would change gs's behavior.

Any ideas?  I can't tell if I'm barking up the wrong tree.

dave
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ghostscript.com/pipermail/gs-devel/attachments/20200207/cb3461fb/attachment.html>


More information about the gs-devel mailing list